Jump to content
hitch

Loading Midi Files In Samp V8 Se

Recommended Posts

Stupid newbie question:

Yesterday I loaded a MIDI file into my piano roll (the first time I've tried to load such a file) and it worked. I was able to use a VSTi drum machine to play a beat. Yay! :) Today, whatever I do, I can't get a MIDI file to load. :D I can play the file in the preview window and the preview window identifies the file as MIDI but then it refuses to load it into a VIP. B) Yesterday a "load MIDI file" dialogue box appeared and everything worked very well. Not so today. Any ideas? Thanks. :(

Share this post


Link to post
Share on other sites

Have you tried:

File

Load/Import

Load Midi File

Share this post


Link to post
Share on other sites

Thanks Derm, but no go.

I've tried File>Load Audio File which brings up the preview window and plays the file but I can't get it to load.

File>Open Project>MIDI doesn't work either. Nor does Shift>M.

Yesterday an "Import MIDI File" box appeared, which gave me the option to place all my MIDI tracks in one VIP track or multiple VIPS tracks, but it hasn't appeared today. I think I must have knocked a lever with my elbow. B) There's probably a really simple thing that I'm missing. Computers... :D

Share this post


Link to post
Share on other sites

hi,

I don't remember if there's an importance if you try to load a midi file without midi track in the vip. So, check that and create first a midi track, and then load your midi file into.

:D

cheers

Phil

Share this post


Link to post
Share on other sites

What version are you using (V8)? I encountered a lot of strangeness importing midi files in 8.

If you open the midi editor, under "Options" there is a setting "Hide Filtered Midi Objects (sic)", make sure this is unchecked.

If that doesn't work and you dont want to wait around for a solution, you can always try deleting the Sam E ini file. This "resets" the program and can cure erratic behaviour. Its in the program folder. It will also reset program preferences etc.

Share this post


Link to post
Share on other sites

Thanks for the suggestions. :( Yes, I'm using V8 SE. I've tried using a MIDI track, making sure the blue MIDI button at the left of the track is on, but it doesn't make any difference. And the "Hide Filtered MIDI Object" option is unchecked too. :D

I can't work out why I'm not getting the "Import MIDI File" dialog box to appear. But two days ago I definitely imported a MIDI drum track into the piano roll and it worked perfectly. My head hurts. B)

Share this post


Link to post
Share on other sites
Despite Derms hint to rename the sam.ini file, make sure that you try to load the MIDI file into a VIP project.

Frank, thank you, but I'd rather not start altering important files if I can help it because I'll probably end up deleting my hard drive by mistake. B) I'm doing what you said, opening up a new VIP and then trying to import the MIDI file, whether it be by hotkey W or Shift>M or Ctrl>I or File>Open Project>MIDI...but no joy. It's very puzzling to know that yesterday I got a dialog box to appear and imported MIDI files easily yet now I can't do it. Anyone got a time machine handy? :D

Share this post


Link to post
Share on other sites

If you just rename the sam.ini file it doesn't harm - just check if the problem is gone then, if not, simply rename the .ini file back to its old name. Copy it before to a save place if you are not sure that you remember the correct name :D

Share this post


Link to post
Share on other sites

How do I find the ini file and what should I do with it? If I rename it then surely Samp won't recognise it? Sorry if I sound nervous but I hate doing stuff like this. I call computers "magic boxes". :D

A good Samp manual would be really handy. B)

Share this post


Link to post
Share on other sites

hi,

How do I find the ini file and what should I do with it? If I rename it then surely Samp won't recognise it?

under Sam folder, simply rename it by add "_old" (like SamE_8_old.ini). When reopen Sam, it will rebuild it.

Or take it and put it out of the folder.

good luck

Phil

Share this post


Link to post
Share on other sites

I took the ini file out of Samp (I hope it was the right file) :D and restarted. No difference. Then I replaced the file and started again. This time I got a "Load MIDI File" box to appear (progress!) but when I select a MIDI file to load, nothing happens. Aargh. B)

Share this post


Link to post
Share on other sites

I'm not a specialist in Midi ... perhaps there's a problem with a midi file format ? is it the same file as you tried when it worked ? Is it from the same soft ? same export ? :D

Phil

Share this post


Link to post
Share on other sites

I've tried MIDI files from different sources (Groove Criminals, Groove Monkees, etc.) and none of them will install. (The only time I've got Samp to import a file, it was a Groove Monkee file.) The preview box identifies them all as "MID" and when I right-click on a file the Properties say that the file is indeed a MIDI sequence. The MIDI editor works fine if I play on a VSTi instrument so it must be some tiny technical issue or setting which is causing the problem. If I could only get that box that offers the option of placing the MIDI files into one VIP track or separate tracks to appear again then I'd be on the right track. Ah well. Sorry to be a nuisance, folks. B)

Samp V8 SE is still fantastic but if I could import MIDI files... :D

Share this post


Link to post
Share on other sites

Try loading the windows MIDI files. Try loading a saved .mid file exported from SAM. Or try loading the new.mid file in Samplitude's "template" folder. Does this work? If so, send one of the other non-working file to me.

Share this post


Link to post
Share on other sites

Frank, I don't know what you mean by "try loading the windows MIDI files" but I followed the rest of your suggestions:

1. I loaded the "NEW" MIDI template. No problem.

2. I loaded the "EMPTY" MIDI template. No problem.

3. I created a MIDI file by tapping out a few notes with a VSTi synth and then used Export Audio>Export MIDI File. I'm such a newbie that it's the first time I've tried to do this. It exported my new MIDI file without a problem.

4. Next I started a new VIP and used Ctrl I to import the MIDI file I had made previously. Success! It loaded the MIDI file I created...but it also created another window with the MIDI file in it for destructive editing. Is this normal?

So that's progress of a sort. At least I know the MIDI function is working ok, apart from not accepting MIDI files that haven't been created in Samplitude already. I'll try to send you an example of the offending file. Thanks a lot. :D

Share this post


Link to post
Share on other sites
4. Next I started a new VIP and used Ctrl I to import the MIDI file I had made previously. Success! It loaded the MIDI file I created...but it also created another window with the MIDI file in it for destructive editing. Is this normal?

I think the shortcut to import a MIDI file into a VIP is Shift+M.

Does it really load the MIDI file into the VIP and opens it for destructive editing at the same time?

You can try to find a tool which converts MIDI files (e.g. from type 2 to type 1 or 0 etc). If you process the non-working MIDI files with them, maybe it then loading works.

Greetings,

Frank

Share this post


Link to post
Share on other sites

Success! :D

I followed Frank's suggestion and downloaded a program that identified the files as MIDI type 1, which Samplitude accepts. Still no joy. Then Frank kindly took a look at the troublesome files for me and suggested that Samp might not like long filepath names. I moved the folder of non-working MIDI files to the root directory on my C:\ drive, pleaded with Samp to have another go...and the files loaded. B)

Frank, thank you very much for the help. :D Now I can unleash my terrible music on the world... :D:D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×