Jump to content
Ringi

Miditiming Problem

Recommended Posts

Habe nun schon mehrmals festgestellt (aber seltsamer Weise nicht immer), dass in manchen meiner Songs, das Midi Timing völlig OUT ist beim Recorden.

Und zwar stellt sich das so dar, das mit jedem Takt mehr die Noten immer mehr zu früh kommen. Quantisieren hilft dann auch nix mehr, von dem mal abgesehen dass ich quantisieren z.B. in einem Basslauf nicht mag, weil der Groove verloren geht.

Von ungenauem einspielen kann nicht die Rede sein :o passiert sogar wenn ich hin gehe und nur viertel Noten auf einem Ton spiele, und so ungenau kann nicht mal meine acht jährige Tochter spielen, dass sie nach 4 Takten knapp ein achtel zu früh spielt.

Jemand ne Idee?

Wenn die Noten jetzt immer später kommen würden, würde ich ja auf Latenz tippen, aber die kommen ja immer früher. :)

Gruß

Ringi

Share this post


Link to post
Share on other sites

Hi,

was für Effekte verwendest Du dann im Song (evtl. sogar Effekte auf der Midispur)?

Welche Sam Version?

Verwendete Engine?

USB Midi Keyboard oder über Midi?

Ist das Miditiming Problem von Anfang da?

Spielst Du zum Sam Click (wenn ja Midi oder Audio Click)

Ich habe das jeztst schon öfter gelesen....Vielleicht kannst Du das VIP mal an den Support weiterschicken. Muss ja irgendwas dran sein.

Mein Timing Problem ist mit 10.1 verschwunden.

Gruß,

Rolf

Share this post


Link to post
Share on other sites

Dieses "driften" der MIDI-Aufnahme wird gelegentlich berichtet, aber wir konnten es noch nie reproduzieren. Manche Audio-Interfaces haben eine grundsätzlich zu hohe Latenz, und beim Versuch MIDI daraufhin anzupassen könnte das Problem auftreten (ist also ein Audio-Treiber-Problem) - so trat es bei einem user mit einer Motu Karte auf.

Ich hoffe die neue Option in V11 die Systemzeit zu nehmen anstatt den Treiber-Timestamp wird deartige Probleme lösen.

Share this post


Link to post
Share on other sites

Rechner: P4 3,0Ghz 3GB RAM

Interface: M-Audio Audiophile 2496 (neuester Treiber)

Engine: MixerFX Monitoring/Hybrid Engine

SAM: 10.2 SE

Klick: SAM AudioClick

Keyboard: Korg T1 :) über M-Audio Midieingang

Im Projekt sind die Spuren vom EZDrummer (als Multichannel) auf 3 Channels den AM-Track als Effekt

diese Spuren sind aber EZDrummer Like per drag n drop eingefügt.

Dann gibt es 1 Rhythmgitarre als Audio (StudioDevil und ein Variverb auf AUX1)

und zuletzt noch eine Sologitarre (StudioDevil und ein Delayeffekt)

und beim einspielen der Bassspur habe ich den Midi "Drift" (wie Frank es so schön nennt) :o

Da ich ja ein LogicUser bis vor kurzem war! Habe ich das ganze mal dort versucht, mit selbigen Spuren und Effekten, dort habe ich kein Midiversatz!

Ich besitze noch ein USB Midiinterface das Midi Uno Sport. Spiele ich mit dem ein, habe ich selbiges Ergebniss (Versatz).

Eine zu hohe Latenz schließe ich persönlich aber auch aus, weil die Midi Noten kommen ja mit jedem Takt mehr immer mehr früher! :P

Schon komisch, oder?

Gruß

Ringi

Share this post


Link to post
Share on other sites
Rechner: P4 3,0Ghz 3GB RAM

Interface: M-Audio Audiophile 2496 (neuester Treiber)

Engine: MixerFX Monitoring/Hybrid Engine

SAM: 10.2 SE

Klick: SAM AudioClick

Keyboard: Korg T1 :o über M-Audio Midieingang

Im Projekt sind die Spuren vom EZDrummer (als Multichannel) auf 3 Channels den AM-Track als Effekt

diese Spuren sind aber EZDrummer Like per drag n drop eingefügt.

Dann gibt es 1 Rhythmgitarre als Audio (StudioDevil und ein Variverb auf AUX1)

und zuletzt noch eine Sologitarre (StudioDevil und ein Delayeffekt)

und beim einspielen der Bassspur habe ich den Midi "Drift" (wie Frank es so schön nennt) :P

Da ich ja ein LogicUser bis vor kurzem war! Habe ich das ganze mal dort versucht, mit selbigen Spuren und Effekten, dort habe ich kein Midiversatz!

Ich besitze noch ein USB Midiinterface das Midi Uno Sport. Spiele ich mit dem ein, habe ich selbiges Ergebniss (Versatz).

Eine zu hohe Latenz schließe ich persönlich aber auch aus, weil die Midi Noten kommen ja mit jedem Takt mehr immer mehr früher! :(

Schon komisch, oder?

Gruß

Ringi

Komisch nicht, aber blöd :)

Ich vermute die M-Audio ist eine Soundcard die besser mit der "Systemzeit" zurecht kommt. Ich bin mir aber echt nicht sicher...

Nützt Dir also nichts...

Vielleicht kann Frank mehr dazu sagen.... :P Umsonst hat er die Systemzeit-Einstellung für V11 ja wohl nicht eingeführt. :o

Gruß,

Rolf

Share this post


Link to post
Share on other sites

So hab viel rumgetestet in der Richtung.

Und herausgefunden: Wenn ich mit Loop eingeschaltet aufnehme ist das so. Ohne Loop nicht! ;)

Da ich jetzt nicht unbedingt MIDI Overdub Aufnahmen mache, ist das grad noch an der Grenze des verzeihbaren :P

Oder gibts ne Lösung?

Gruß

Ringi

Share this post


Link to post
Share on other sites

Mein Post drüber war doch en viel zu früher Trugschluss. Das war es doch nicht. ;)

Aber ich habe noch folgendes herausgefunden, und das muss es nach 2 stündigem und mehrfachen neuem Programm starten, neuen Songs generieren und Testen gestern abend auch letzlich sein:

Ich fügte meine Instrumente immer so ein:

Plugins -> VSTi (Instrument wählen) -> Simple: Audio und Midi .... (oder bei EZDrummer Multichannel (Stereo/Mono Standard)

Gehe ich nun aber hin und füge die Instrumente direkt unter

Midi --> Out --> Neues Instrument (Instrument wählen) ein, habe ich diesen Midiversatz nicht mehr.

Frank oder Rolf? Könnt ihr euch das erklären? Wenn ja, worin liegt denn nun genauer der Unterschied beim einfügen der Instrumente in meinen beiden Vorgehensweisen (vom Multichannel mal abgesehen, also nur bei Simple)

Viele Grüße vom Bodensee

Ringi

Share this post


Link to post
Share on other sites

Hi Ringi,

per Midi Out Menü ist klar...der andere Weg ist mir nicht ganz klar. Du meinst Du wählst hier per Spurbox die VST I aus...oder Mixer -

schreib das noch mal genau auf.

Und teste dann noch mal. Wenn Du das noch mal bestätigen solltest, teste ich es selbst am WE auch noch mal.

Gruß,

Rolf

Share this post


Link to post
Share on other sites

Ok, nochmal mein "alter" Weg mit bildern (Outfit von SAM noch sehr sporadisch, da ich gestern noch ne Neuinstallation durchgeführt habe bei meinem Testen:

Über Plugins das Instrument "holen":

post-16328-1243593052_thumb.jpg

Dann "Simple" im Dialog wählen (und beim EZDrummer nehme ich da eben Multichannel)

post-16328-1243593037_thumb.jpg

Dann sieht das so aus und ich habe das Problem mit dem Midi, dass die Noten früher kommen als gespielt (passiert im übrigen in dem Moment wenn ich die Aufnahme stoppe, gut sichtbar bei hohem Zoom):

post-16328-1243593061_thumb.jpg

Gruß

Ringi

Share this post


Link to post
Share on other sites

Danke.

und zu was für einer Referenz spielst Du ein (midi click, audio click, audiofile?)

Wie weit ist es bei Dir verschoben?

Welche Engine?

Asio und Bufferwerte?

Dann teste ich mal ;)

Gruß,

Rolf

Share this post


Link to post
Share on other sites

die Werte stehen weiter oben :P

Asio Buffer steht auf 256. Ist aber mit 512 unverändert!

Wenn ich z.B. in Tempo 90 in 2 Takten nur viertel Noten spiele, ist die letzte Viertel Note mehr als ein 16tel nach vorne verschoben.

Gruß vom (wieder) sonnigen Bodensee ;)

Share this post


Link to post
Share on other sites

So ein Versatz ist natürlich extremst. Das klingt einfach nur nach einem Treiberproblem...und da fürchte da ist derzeit auch nichts zu machen.

Ich dachte wir reden von kleineneren Versätzen. Vielleichzt hast Du die Möglchkeit das mal in Cubase zu testen - die bieten auch die Option die "Systemzeit" zu verwenden. Ich vermute Deine Card braucht das auch.

Gruß,

Rolf

Share this post


Link to post
Share on other sites

Ringi, während der Aufnahme sieht es noch gut aus? Oder läuft der Play(Record)-Cursor schon dem wachsenden Objekt-Ende davon? Und bei Klick auf Aufnahme-Ende rutschen dann die Noten nach vorne (je weiter hinten liegend, um so mehr)?

Share this post


Link to post
Share on other sites
Ich fügte meine Instrumente immer so ein:

Plugins -> VSTi (Instrument wählen) -> Simple: Audio und Midi .... (oder bei EZDrummer Multichannel (Stereo/Mono Standard)

Gehe ich nun aber hin und füge die Instrumente direkt unter

Midi --> Out --> Neues Instrument (Instrument wählen) ein, habe ich diesen Midiversatz nicht mehr.

Viele Grüße vom Bodensee

Ringi

Das habe ich jetzt ausprobiert und alles ist o.k. Bist Du Dir echt sicher?

Gruß,

Rolf

Share this post


Link to post
Share on other sites
Ringi, während der Aufnahme sieht es noch gut aus? Oder läuft der Play(Record)-Cursor schon dem wachsenden Objekt-Ende davon? Und bei Klick auf Aufnahme-Ende rutschen dann die Noten nach vorne (je weiter hinten liegend, um so mehr)?

Das habe ich jetzt mal beobachtet und: Ja, der Cursor ist immer ein Stückchen vor dem Ende des wachsenden Objektes und beim klick auf Stop...flupp! ;)

Share this post


Link to post
Share on other sites

Man kann es glaub optisch schon recht gut erkennen was passiert.

4 Takte in Tempo 100 ein einziger Ton als viertel gespielt:

post-16328-1243765656_thumb.jpg

und so "genau-ungenau" ;) kann man gar nicht spielen :P

Share this post


Link to post
Share on other sites

In neinem betagten Logic sieht das dann so aus:

post-16328-1243768013_thumb.jpg

;)

Nicht 100 prozentig, aber das sind eben die 128tel spielfehler die jeder hat.

Share this post


Link to post
Share on other sites

Weiß keiner Rat? ;):P

Ich bin mit meinem Latein am Ende...

Es bleibt wie es ist, egal was ich drehe und verändere!

An meinem Dual Screen den ich seit paar Wochen habe kanns nicht liegen, oder?

Gruß

Ringi

Share this post


Link to post
Share on other sites

Vielleicht ein ganz blödes 44,1/48 kHz Problem?

Ansonsten hoffe ich, dass solche Probleme mit der neuen Option in V11 ("Systemzeitstempel benutzen" anstatt "Treiber Timestamp") gelöst sein wird.

Share this post


Link to post
Share on other sites

Ich hab hier das gleiche Phänomen mit V10SE:

Soundkarte: Mindprint Trio USB, 44kHz Samplerate,

während eines 8-taktigen Motivs geht das Timing immer mehr aus dem Leim. Komischerweise habe ich in dem Projekt bereits Drumspuren eingespielt, und da ging das einigermassen.

Jetzt nehme ich den Soundfontplayer mit Pianosample und Peng, keine Aufnahme möglich...........! :blink:

Sehr nervig, dass

Der Gegenversuch mit meinem ollen Tracktion3 ist völlig ok, schein also nicht am Treiber zu liegen....

Vielleicht hilfts

Marc

Share this post


Link to post
Share on other sites

Ja das ist dann schon sehr sehr dubios. :blink:

Bei meinem betagten Logic 5.5.1 tut das ganze völlig Problemlos.

Ich habe ja versucht und gemacht in der vergangenen Woche, da ich Urlaub hatte. Ich habe den 2. Monitor abgeklemmt, neue Treiber für die Grafikkarte rein (man weiß ja nie), alte Treiber für Audiophile versucht (2 Stück)...und wie Marc vor mir beschrieben hat: Plötzlich gings als wieder. SUPER dachte ich. Am nächsten Tag ran an ein Projekt und peng! war es wieder so wie vorher. Ich wollte mir ja echt ne "große" SAM10 holen, aber so wie das gerade im Midi Bereich bei mir "muckt" muss ich echt abwarten. Hoffe es gibt von SAM11 dann ne Demoversion wo ich das erst mal testen kann! Solange werd ich wohl doch wieder mit Logic weitermachen. :blush:

Aber da hab ich halt echt solangsam Probleme mit den neueren VST Plugins und brauch ne zweite Bootoption mit ner MAXMEM=1024 Option

Und die neuen Features (z.B. Freeze, offline Bouncing, MP3 Support...) von SAM und der Mischer fehlen mir jetzt halt auch :D

Ich bin aber guter Hoffnung auf SAM11

Gruß

Ringi

Share this post


Link to post
Share on other sites

Also ich habe genau das gleiche Problem. Ich will mir eigentlich Samplitude Music Studio 16 zulegen.

Im alten Logic alles auf den Punkt genau in Time, bei Sam driften die Takte ab.

Leider ist das Programm so völlig unbrauchbar.

Habe ein Tascam US122.

Share this post


Link to post
Share on other sites

Lade Dir doch mal die Testversion vom neuen Music Studio 16 runter. Evtl. ist da ja die Option "Systemzeitstempel benutzen" ebenfalls vorhanden.

..und wenn Du es machst gib mal Feedback.

Gruß,

Rolf

Share this post


Link to post
Share on other sites

Jep, der Punkt ist dabei.

Und siehe da ohne den Haken, das gleiche Ergebniss wie mit der 10er Version und mit dem Haken in der MusicStudio16 Version passt alles (bis auf meine kleinen "Versätze") :lol:

Also scheint das wohl wirklich daran zu liegen...???

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×