Jump to content
mudflat

Controlling Variverb

Recommended Posts

I want to control Variverb with my Nocturn. How do I get V-verb to respond to the CC's coming in from the Nocturn? I've tried both learn methods with no success.

Share this post


Link to post
Share on other sites

unfortunately variverb doesnt support that kind of controlling. due to its internal processing of incoming and outgoing automation messages the requirements for the learning mechanism for hardware controller are not met.

Share this post


Link to post
Share on other sites
unfortunately variverb doesnt support that kind of controlling.

The Nocturn can operate in Automap mode but also as a normal CC controller. Surely variverb can be controlled with CC's in that way or else why would it have the learn function programmed into it? I understand how the two learn modes operate in theory. Are you saying under no circumstances can variverb be controlled with a hardware mixer?. That the learn function is only for use with the track automation.

Do I have to configure the Nocturn, operating in normal CC, mode in the System Options-Hardware Controller setup? I know there no template for it but perhaps one could be created.

Share this post


Link to post
Share on other sites

VariVerb can be automated via standard Midi CC messages, as it says on the UI (and in the manual). At least is does here using 'ordinary' Midi equipment.

I don't have access to a Nocturn here, so I can only ask you to try that again yourself and refer to the unit's CC mode.

But: I do recall some problems with Novation's Automap a while back but I currently don't have access to those documents. Should your problem persist, let us know and I'll dig that out asap. Quick check: Are you using the regular/unlocked VST? AFAIR, the demo of VV wasn't initialised properly by Automap as one of the restrictions is '0 parameters to the VST interface', therefore no automation and no saving with a host project. Automap, at that time, insisted on VST automation data. Is it perhaps that?

Share this post


Link to post
Share on other sites
VariVerb can be automated via standard Midi CC messages, as it says on the UI (and in the manual). At least is does here using 'ordinary' Midi equipment.

I don't have access to a Nocturn here, so I can only ask you to try that again yourself and refer to the unit's CC mode.

But: I do recall some problems with Novation's Automap a while back but I currently don't have access to those documents. Should your problem persist, let us know and I'll dig that out asap. Quick check: Are you using the regular/unlocked VST? AFAIR, the demo of VV wasn't initialised properly by Automap as one of the restrictions is '0 parameters to the VST interface', therefore no automation and no saving with a host project. Automap, at that time, insisted on VST automation data. Is it perhaps that?

Sascha,

Thanks for chiming in. I am using the version that comes bundled with Samp. I have tried using Automap with variverb in the past and had no joy. When the verb was inserted using the Automap wrapped version it came up as the parameter dialog rather than the usual GUI. The usual GUI was not available. So I decided to give it another go using the Nocturn as an "ordinary" midi controller which it also is capable of, as well as doing it's Automap thing.

However, today I shelved trying to use the Nocturn as an ordinary controller and gave Automap another go and I've now got it working almost perfectly. :blink: I figure this may well be something to do with the Automap 3 update. Nothing's changed in Samp or the variverb recently. All that doesn't work is the v-verb GUI graphics don't change with any Nocturn tweaks. But it's only the fancy graphics. The numerals on the verb GUI are updated, the knob positions and the actual audible sound parameter changes are updated correctly too. When the plug is loaded and the GUI opens it comes up extremely small and cannot be resized; but when it is closed and re-opened it returns at the correct size. So none of these minor issues are that important at all. Main thing is I finally have maximum knob on control of all the many v-verb parameters. Including all the HQ source and mic positioning. IT'S ALIVE!!

A good day.

Share this post


Link to post
Share on other sites

thank you for that!

now i will try again with my nocturn :)

i put it aside because of the parameterview-thing you mentioned.

mathias

Share this post


Link to post
Share on other sites
thank you for that!

now i will try again with my nocturn :)

i put it aside because of the parameterview-thing you mentioned.

mathias

Mathias, if you have any problems PM me. I got it mapped out already and you can have my map if you want it. Though you probably will want to make one for yourself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×