Jump to content
porkyman

3 problems. midi, duplicate, and plugin folder.

Recommended Posts

1. i can not for the life of me get the midi to work. im using an optimus md-1200 (radio shack brand but it has worked on pt, cubase, s1, and x2 for 15+ years). i have never had a problem in any other DAW previously mentioned. i hit "y" midi / mbox control. set both global record and play to mbox. gone to track editor selected mbox control on "in. loaded instrument. i selected record and input monitoring. it plays when i hit the little keys on plugin, but im not getting a signal from my keyboard. its not even registering in fade levels. ive watched all kraznets videos. there doesnt seem to be an answer.

2. when i select a region and duplicate "ctrl + D" it jumps to somewhere else in the track and does something. i dont know what. the only way i am able to work around this is copy and paste. it is really slowing me down.

3. there doesnt seem to be any coherent method for finding plugins. samp put absolutely ZERO effort into this, its really amateur. i feel like magix is trying to coerce me into only using their plugins. if they can neatly organize theirs. why cant i do the same for mine. for ex. why cant i put all my 3rd party comps in 1 dynamics folder? this is the 12th version for gods sake!!! people have been working like this for over 20 years??? its craziness!!! there has to be a remedy.

Share this post


Link to post
Share on other sites

1. Did you use Hybrid Engine Monitoring mode and Mix input and Playback is ticked?

2. crtl + d duplicates objects, simply create them with one or more splits, Auto Crossfades "on"

3. y - effects - vst/directx setup: click on the little folder icon and point to your plugins and scan. If you are using multiple paths, do this again until all your paths are scanned.

Share this post


Link to post
Share on other sites

thanks for responding werner.

1. i have y / audio settings / monitoring set up all the way to the right to where it says " mixer effects monitoring / hybrid engine. pink record light lit and blue speaker button lit. the sound is coming through the speakers with the plugin keyboard. im just not able to trigger it with external keyboard. i went back in to cubase last night to make sure it wasnt any of the hardware and it worked perfectly, so its definitely samplitude.

2. thanks ill try that

3. all my plugins are loaded, they just have no organization at all. cubase organized them automatically. so did protools. i was shocked at how many plugins i actually had. when i click on vst it literally covers the whole screen. is there a way to better organize them by group like "dynamics," or "eq" etc?

Share this post


Link to post
Share on other sites

Glad you sorted it out. I admit that the plugin organisation is not up to date. You can organize your plugins very well, but until now, you have to do that manually.

Share this post


Link to post
Share on other sites

>why cant i put all my 3rd party comps in 1 dynamics folder?

I don't know about Pro X, but in Samplitude 11 I did this to all my VST plugins. Go to the VstPlugins folder, create subfolders for the different catagories you want, then copy the VST DLL files into the proper folder. Restart Samplitude, and presto. Tip: I put parenthesis around my folder names so they are grouped together in Explorer. For example:

(Dynamics), (Reverbs), (Delays), etc. Makes it easier to move the DLL files into them.

Share this post


Link to post
Share on other sites

>why cant i put all my 3rd party comps in 1 dynamics folder?

I don't know about Pro X, but in Samplitude 11 I did this to all my VST plugins. Go to the VstPlugins folder, create subfolders for the different catagories you want, then copy the VST DLL files into the proper folder. Restart Samplitude, and presto. Tip: I put parenthesis around my folder names so they are grouped together in Explorer. For example:

(Dynamics), (Reverbs), (Delays), etc. Makes it easier to move the DLL files into them.

YOU CANT DO THAT WITH WAVESSHELL

Share this post


Link to post
Share on other sites

I found a workaround for WAVESHELL or similar plugin sets. It's a bit of a hassle, but it does work. You might want to try changing a couple lines as described below and verify it is working before you spend a lot of time changing all the WaveShell lines.

1. Close Samplitude, then locate and edit its VstPlugins.ini file. (Mine was in C:\Program Files (x86)\MAGIX\Samplitude11). You should make a copy first, incase something gets messed up.

2. In that file, search for WaveShell. There will be a lot of lines in that section that tell Samplitude about each Waves plugin found in WaveShell. For example, the lines for the C1-Compressor look like this on my test system.

"C:\Program Files (x86)\Steinberg\VstPlugins\WaveShell-VST 9.0.dll@434D504D",2097152,"C1 comp Mono","WaveShell-VST 9.0",FFFFFFFF
"C:\Program Files (x86)\Steinberg\VstPlugins\WaveShell-VST 9.0.dll@434D5053",2097152,"C1 comp Stereo","WaveShell-VST 9.0",FFFFFFFF


Notice each line has "WaveShell-VST 9.0" near the end of it. Samplitude apparently uses that text as the "group name" in its VST submenu.

3. Edit each line, changing the "WaveShell-VST 9.0" to a group name appropriate for each plugin. For example, I changed the C1 Compressor to show up in a "(Dynamics)" submenu like this ...

"C:\Program Files (x86)\Steinberg\VstPlugins\WaveShell-VST 9.0.dll@434D504D",2097152,"C1 comp Mono","(Dynamics)",FFFFFFFF
"C:\Program Files (x86)\Steinberg\VstPlugins\WaveShell-VST 9.0.dll@434D5053",2097152,"C1 comp Stereo","(Dynamics)",FFFFFFFF


4. Save the file and reload Samplitude.

IMPORTANT - If Samplitude ever updates your VstPlugins.ini file afterwards, all your changes will be undone. To be able to recover from this, make copy of VstPlugins.ini after making all your changes. Then you will be able to cut and paste the lines you changed from the copy back into VstPlugins.ini.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×