Jump to content
spamer68

Magix low latency driver stopping screenreader speech on start up.

Recommended Posts

Hi, a lot of screenreader users are experiencing a pretty big issue when opening Samplitude X3. in many cases the Magix low latency driver is selected by default, so when the program is open, it takes over the screenreaders output, hence stopping the speech.  Of course, this stops the user from navigating to the system options in order to select another mode/driver, e.g, Asio/WDM. Also, another issue is that the low latency driver seems to become the default in other DAW's like Sonar, if the user has this already installed. Is there a way to make another driver mode the default on start up? I never experienced this in X2, as MME always seemed to be the start up mode. THX Steve.

Share this post


Link to post
Share on other sites

yes its new in prox3 that the default driver is the asio driver. so what we can do is to save in the accessibility inz container that it takes wdm or mme as default.

 

Share this post


Link to post
Share on other sites

Thanks Tom. So, is this something I can do here? or is it something that needs to be done by Magix?  I know we can save the audio/midi information into the .inz file, but if I did that, wouldn't that save my specific audio?  What would happen if another user then loaded that on their machine?  If I can do it, I will do it, just let me know. THX steve.

Share this post


Link to post
Share on other sites

Tom, it's been pointed out...and I didn't think of this at time of posting, but adding this to the .inz wouldn't help, as the user would still have to access the system options in order to load the .inz file!  They wouldn't be able to do this, because the Magix low latency driver would be active, so it's the same situation. Steve.

Share this post


Link to post
Share on other sites

i think that at the welcome dialog where you can change to the accessibility inz the asio driver is not loaded yet. so can you tell me, is the screenreader blocked when you have the welcome screen? or is it blocked after the welcome dialog?

Share this post


Link to post
Share on other sites

Tom, for me, yes that's correct. I've asked other users to report back or to post here. BTW, is there a way to disable this driver anywhere, as it is wrapping the drivers in other programs like Sound Forge etc. It's working like AsioForAll. Just asking, as many users won't even need it. THX steve.

 

Share this post


Link to post
Share on other sites
On ‎09‎.‎12‎.‎2016 at 1:21 AM, spamer68 said:

Tom, for me, yes that's correct. I've asked other users to report back or to post here. BTW, is there a way to disable this driver anywhere, as it is wrapping the drivers in other programs like Sound Forge etc. It's working like AsioForAll. Just asking, as many users won't even need it. THX steve.

 

Still waiting answer of that question also, Magix low-latency driver is really problem for other softwares, which Steve mentioned before.
At a result, we are looking for a solution to disable Magix Low Latency driver...

Share this post


Link to post
Share on other sites

Hi! At the german Version of Pro X3 ther is another problem. The JAWS Screen Reader doesn't stop working, but it seems that Samplitude wants to load the Low latency Driver and has then an error message that it can't be loaded, although the normal ASIO Driver is set in the System Settings. That error message returns if I try to reboot the software with the start dialogue. My Standard ASIO Sound Driver is a Steinberg Interface. At University I use the UR22 Interface on our University computer, at home my Standard Interface is the Steinberg UR44 Interface.

Share this post


Link to post
Share on other sites

Steve, did I understand you correctly that your Screen Reader stops working, if Samplitude asks for the Low Latency Driver?

Share this post


Link to post
Share on other sites

Saw the following on this on our VIP Audio listwhich is the Samplitude Access support E-mail list for visually impaired users:

 

Hi all. I had Jim Roseberry help me get my audio set up, because when I loaded samplitude, JAWS and other synthesizers went silent. I am using the on board Realtek sound card for JAWS, and my mackie Onyx mixer for Samplitude and other audio.

He discovered that the Magix low latency driver had moved my other audio drivers one slot over in the order in which they were being called for. So Samplitude and Sound Forge would not allow the Realtek card to work. Thus, No JAWS.

He uninstalled the Magix driver in the registry and now it works as it should.

 

Phil comments: Previously this was not a problem prier to Samplitude Pro X3 as the Magix driver was an MME driver. In my view the default behaviour for this driver should be that it’s not enabled at all. There should be a section in the start menu under programs, Magix, Samplitude Pro X3 Suite where end users can configure it. In this section you could have an entry to enable it and a second to disable it. All the entry would have to do is apply the appropriate registry key. I note that Sound Forge uses a second and equally annoying driver which by default should not be enabled as it can wreak havoc with screen reading software.

Share this post


Link to post
Share on other sites
On ‎08‎/‎12‎/‎2016 at 9:35 AM, TomW said:

i think that at the welcome dialog where you can change to the accessibility inz the asio driver is not loaded yet. so can you tell me, is the screenreader blocked when you have the welcome screen? or is it blocked after the welcome dialog?

Phil comments: yes Tom you are correct. However if an end user does not use the quick start dialog then it's possible to end up in a situation where the Magix Low Latency driver is enabled and takes over.

 

Share this post


Link to post
Share on other sites

I'm glad to know I wasn't the only one having this issue. I purchased Samplitude last December and while in the system dialog, as I was choosing my ASIO driver, my JAWS completely stopped after the Magix driver was selected. I had to power down my computer and re-start the process. By chance, the Saffire Asio was selected and the problem went away. I have since disabled the driver in the registry using the tweak that was mentioned on the VIP list.

 

 

 

Share this post


Link to post
Share on other sites

hello,

is this issue now finished? or is there something to do still? I am not sure if everything works now as it should.

Share this post


Link to post
Share on other sites

I had to uninstall Sound Forge Audio Studio 12 to get rid of the driver. It was interfering with the latency on my system. And I don’t want to make it work. I didn’t pay for it. I did pay for Sound Forge. I did install version 10 and it works much better.

Share this post


Link to post
Share on other sites

I found a soulution to this problem. I dont know if it is deleting the drivers completely, but it makes them go away.

I found it on the Cakewalk Forum.

"To get rid of the Magix Low Latency ASIO driver:
 
Go into the Registry...
HKEY_LOCAL_MACHINE\SOFTWARE\ASIO - delete the Magix Low Latency ASIO driver entry
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ASIO - delete the Magix Low Latency ASIO driver entry
 
Note:
If you've got a piece of hardware that functions as an ASIO audio interface (and you know you don't want to use it), you can use this same procedure to eliminate that particular ASIO driver."
 
 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×