Jump to content
Larry Jones

How Do I Stop These "Record Errors"?

Recommended Posts

After recording any audio track, Samplitude gives me a popup titled "Recording Finished," and in it there is the message "50 Record Errors occurred. Continue?" The number could be 10 or 50 or 100, but it's usually a very high number, double-digits at least, even for a 30-second clip. When I click the "Yes" button Samplitude inserts a marker for every record error. When I play back my track, I cannot hear any problems with the recorded audio. No glitches, no pops, no distortion. The track is completely satisfactory to me, but now I have a bunch of error markers on my timeline, making it difficult to see the real markers that I put there myself.

I appreciate the warning that there might be something wrong with my recording, but so far these have all been false alarms, and the warning leaves me with a mess in my marker track. So how can I stop these error warnings? Or can I at least stop Samplitude from inserting all those markers?

Thanks for any advice!

Share this post


Link to post
Share on other sites

I've had the same problem in the past with various Music Studio versions (2013 and 2014). At that time I found somewhere the solution for this problem that is obviously caused by the Focusrite interface or driver. I've just tested it also with my new Pro X3 - and it worked as well!

Add this line in the INI file (according to your version, e.g. "Sam_x64.ini"), as a new line below the [Setup] entries.

DisableDroppedASIOBufferSWDetection=1

(Just to be safe, please copy and rename the original INI file first to have a backup if there would be any problem!)

After restarting your problem should be gone.

Share this post


Link to post
Share on other sites

hi

I would prefer to know why I have errors than disable the warning... ;)

Perhaps you just record with a very low latency setting, or in Hybrid Mode + lot of plugins ? or you could have a real problem with intaface and driver. Even if you found that 'you think) it's false alert, it's not normal to have as much error...

cheers

Phil

Share this post


Link to post
Share on other sites

Hi again, I’ve found this in a German recording forum from 2013. This was the original answer from the Samplitude support:

Mit dem Focusrite Scarlett USB wurden kontinuierliche Spikes im Treiber festgestellt, die zur Auslösung von LAB in Samplitude führen. Dies deutet auf ein Double-Buffering des Interfaces hin. Audiotechnisch ist das Interface aber in Ordnung und funktioniert ohne Fehler im Audiosignal. Zur Deaktivierung der LAB Fehleranzeige folgenden ini-Eintrag verwenden: "[Setup] DisableDroppedASIOBufferSWDetection=1"

Translation (online, I hope it works to understand):

With the Focusrite Scarlett USB continuous spikes in the driver are detected, which lead to triggering of LAB in amplitude. This indicates a double buffering of the interface. However, the audio interface is fine and works without any errors in the audio signal. To deactivate the LAB error display, use the following ini entry:"[Setup] DisableDroppedASIOBufferSWDetection=1".

So, if your system has "enough" performance power, your basic asio/buffer settings are OK and you don’t hear any "audio errors", then you can ignore this error and disabling it this way.

Btw: according to my researches (then and now) many users do have exactly this problem, and only with focusrite interfaces / drivers but not e.g. with the "Magix low latency driver" (while using the same interface)...

Share this post


Link to post
Share on other sites

Thanks for the update - I've seen this problem too but very intermittently

 

Share this post


Link to post
Share on other sites

I was having the same problem. I installed the beta drivers for my Scarlett 18i20 and that solved the problem. Before I updated to the beta driver I used the fix above ( DisableDroppedASIOBufferSWDetection=1" ). All was good for awhile but then the LAB messages started to rear it's ugly head again. I don't know why but it did return. I also contacted tech support to see if they could help. I've copied their e-mail reply below. I didn't have a need to try the fix because in the meantime I installed the beta driver and that is what worked for me. I can upload the file for you to try if you'd like. Just let me know. 

Dear George,

Thank you for your message.
Our  developerteam says this is a inconsistent interpreation of errors specially with the Focurite productline. You will be able to deactivate the recognition with the attached setting.
Please move per drag and drop this inzfile to the empty Samplitude Surface.

--
With kind regards

Ed Myer

 

Share this post


Link to post
Share on other sites

getting rid off those pesky AQ markers:-

 

in wave editing view (right click the offending take and select from menu) ...

 

 

right click on any AQ marker, select "delete all markers" .. a pop will say "would you like to delete all markers?" click delete ..

all the AQ markers will get deleted leaving the "normal" markers intact ...

bear in mind there is no undo for this,so save if your sure its what you want (those AQ markers must have a purpose) ...

 

no idea what the cause/fix is for this ... yet (i get the problem with my old soundcard)

Share this post


Link to post
Share on other sites
16 hours ago, Nordlead said:

Add this line in the INI file (according to your version, e.g. "Sam_x64.ini"), as a new line below the [Setup] entries.

DisableDroppedASIOBufferSWDetection=1

Nordlead - Thank you for this! I attempted to try this solution today, only to discover that there is no Samplitude .ini file on my PC, except for those in the "Uninstall" folder. I have used the Windows search function to look for "Sam*.ini" and nothing is found.

6 hours ago, Geo524 said:

I also contacted tech support to see if they could help. I've copied their e-mail reply below. I didn't have a need to try the fix because in the meantime I installed the beta driver and that is what worked for me. I can upload the file for you to try if you'd like. Just let me know.

Geo524 - It would be great if you could upload the file. As mentioned above I have tried the .ini file fix, but I don't seem to have the .ini file. Do you recall what version of Samplitude you were using at the time?

 

5 hours ago, HHfallback said:

getting rid off those pesky AQ markers:-

HHfallback - Thanks so much! Until I get this resolved I'll be using this method. There are so many of these markers I literally can't even find the real markers that I need to navigate the project, and "delete all markers" from the timeline does just that: all markers, including the "good" ones.

 

12 hours ago, Philw said:

I would prefer to know why I have errors than disable the warning.

Philw - From the other replies to my original post, I conclude that disabling the warning is the right way to deal with this. The warnings alert me to a problem that does not exist. But thanks for the thought.

Share this post


Link to post
Share on other sites

Hi Larry,

I am using Samplitude Pro x3 Suite. I bought into the amazing $149.00 deal when Gibson gave us Sonar users the shaft. Lol. 

Here's the link to the file that tech support sent me. https://app.box.com/s/pu1r8vqzzcdp4w45c9zvspp5k5h7by10 

Please keep in mind that 1) I did not use this so I don't even know if it will work or not

and 2) it might just be a shortcut to the same fix already mentioned above. ( DisableDroppedASIOBufferSWDetection=1 )

Drag the file to the empty Samplitude surface. Good luck and I hope this helps resolve the LAB message.

 

PS If the link above does not work I will email you the file. PM me with your email address.

Share this post


Link to post
Share on other sites
8 minutes ago, Geo524 said:

and 2) it might just be a shortcut to the same fix already mentioned above. ( DisableDroppedASIOBufferSWDetection=1 )

 

thanks :)

i just unpacked this (did not run ((drag over)) but that is indeed what it appears to do :)

Share this post


Link to post
Share on other sites
9 minutes ago, HHfallback said:

thanks :)

i just unpacked this (did not run ((drag over)) but that is indeed what it appears to do :)

Hi Larry,

I am using Samplitude Pro x3 Suite. I bought into the amazing $149.00 deal when Gibson gave us Sonar users the shaft. Lol. 

Here's the link to the file that tech support sent me. https://app.box.com/s/pu1r8vqzzcdp4w45c9zvspp5k5h7by10 

Please keep in mind that 1) I did not use this so I don't even know if it will work or not

and 2) it might just be a shortcut to the same fix already mentioned above. ( DisableDroppedASIOBufferSWDetection=1 )

Drag the file to the empty Samplitude surface. Good luck and I hope this helps resolve the LAB message.

Share this post


Link to post
Share on other sites

HHfallback,

 

I had a sneaking suspicion it did the same thing. I hope it works but as for me the LAB's came back. I ended up having to install the Focusrite beta driver for my Scarlett 18i20 to solve it. 

 

Incidentally I believe the .ini file is Magix>Samplitude ProX3>ProgramData>x64 or something like that? 

Share this post


Link to post
Share on other sites
1 hour ago, Geo524 said:

Here's the link to the file that tech support sent me. https://app.box.com/s/pu1r8vqzzcdp4w45c9zvspp5k5h7by10 

Please keep in mind that 1) I did not use this so I don't even know if it will work or not

and 2) it might just be a shortcut to the same fix already mentioned above.

Geo524 - This works! Or at least it did on the first thing I recorded after running it. Thank you for the great public service. It's beyond the call of duty.

BTW, I just have a first generation Scarlett 6i6. No beta driver available. I wonder if I should get a 2nd gen replacement -- I think they use a different driver.

Kraznet - You might want to check with the support guys and see if it's a good idea to post this fix somewhere for future Focusrite owners.

Share this post


Link to post
Share on other sites

@Larry Jones thinking about it - i cant remember if you have a hardware controller or not,but if you do sam has  a "marker select Vpot" setting you can assign to a spare rotary (or use with a modifier button) .. its great to spin a rotary and go from marker to marker :D

Share this post


Link to post
Share on other sites
5 minutes ago, HHfallback said:

@Larry Jones thinking about it - i cant remember if you have a hardware controller or not,but if you do sam has  a "marker select Vpot" setting you can assign to a spare rotary (or use with a modifier button) .. its great to spin a rotary and go from marker to marker :D

I have a Nektar LX-61+. It's a MIDI controller but it has a limited control surface built in. You can download drivers for it that are designed for your specific DAW. I got it to use with SONAR. Sadly, it does not offer control for Samplitude. I may some day have a run at customizing it for Samplitude, but I'm pretty comfortable with QWERTY keyboard control.

Share this post


Link to post
Share on other sites
16 minutes ago, Larry Jones said:

I have a Nektar LX-61+. It's a MIDI controller but it has a limited control surface built in. You can download drivers for it that are designed for your specific DAW. I got it to use with SONAR. Sadly, it does not offer control for Samplitude. I may some day have a run at customizing it for Samplitude, but I'm pretty comfortable with QWERTY keyboard control.

nice keyboard! /wants

"Nine 30mm faders, 9 MIDI buttons and 8 encoders are at the center of Impact LX+'s control panel. Each control is fully programmable to send any MIDI CC message"

 

you could make a real usable template in sam,without making any changes to the Nektar  .. have a play in hardware controller settings,was a bit hard for me to grasp at first,but once i did i can make it do virtually anything .. my templates are still in the making :D

(save 3 buttons for shift,ctrl and option,they treble up your button,knob count ;) )

 

Share this post


Link to post
Share on other sites

 

8 minutes ago, HHfallback said:

nice keyboard! /wants

"Nine 30mm faders, 9 MIDI buttons and 8 encoders are at the center of Impact LX+'s control panel. Each control is fully programmable to send any MIDI CC message"

I must admit that at this stage of my life I am no longer a professional, and I don't have a lot of money to spend on my hobby. I had an old hand-me-down Roland D-50 that I was using as a MIDI controller for many years, and when it finally gave up the ghost I had to have something (It's always easier to justify the expense when you "don't have a choice"). The Nektar is quite affordable, and the control surface was a bonus. If you want one, I can't think of any reason not to get one. Of course, if you are a real keyboard player (I'm not), you might not like the action or something like that, but for functionality it does all I hoped for.

Share this post


Link to post
Share on other sites

i cant play keyboards to save my life,but for some things there a must .. i have an old controller that came with cakewalk,that thing feels terrible,but it works .. when it finally dies i`ll have to get another :D

 

are you a guitar player mainly ? if so check this out,i have hardware guitar to midi,but this is very comparable - Jam Origin (i tested a lot while it was in beta)

https://www.jamorigin.com/

looking on the daw setup page i see Kraznet has done a setup video,so that will be great :D

Share this post


Link to post
Share on other sites

I was having the same problem. I installed the beta drivers for my Scarlett 18i20 and that solved the problem. Before I updated to the beta driver I used the fix above ( DisableDroppedASIOBufferSWDetection=1" ). All was good for awhile but then the LAB messages started to rear it's ugly head again. I don't know why but it did return. I also contacted tech support to see if they could help. I've copied their e-mail reply below. I didn't have a need to try it because in the meantime I installed the beta driver and that is what worked for me. I can upload the file for you to try if you'd like. Just let me know. 

Dear George,

Thank you for your message.
Our  developerteam says this is a inconsistent interpreation of errors specially with the Focurite productline. You will be able to deactivate the recognition with the attached setting.
Please move per drag and drop this inzfile to the empty Samplitude Surface.

--
With kind regards

Ed Myer

 

Share this post


Link to post
Share on other sites

Glad it worked for you Larry. From what I heard the Scarlett Gen 2 also has issues with Samplitude so I'm not sure upgrading would be of much help? Focusrite tech support did say they are working on new drivers for all the Gen 1 Scarlett interfaces. He did not have a release date but assured me they are working on it. Keeping fingers crossed it will be soon. In the meantime everything's good. 

Share this post


Link to post
Share on other sites
39 minutes ago, Geo524 said:

Glad it worked for you Larry. From what I heard the Scarlett Gen 2 also has issues with Samplitude so I'm not sure upgrading would be of much help? Focusrite tech support did say they are working on new drivers for all the Gen 1 Scarlett interfaces. He did not have a release date but assured me they are working on it. Keeping fingers crossed it will be soon. In the meantime everything's good. 

Well, it worked here, and lucky it did because I couldn't find the .ini file anyway. :mellow: I just dragged it into Samplitude. After a few seconds I got a popup asking me if I wanted to save the project I had open. I saved it and the program closed by itself and reopened. The error messages were more an annoyance than anything else. I saved your file, and I'll re-use it if the problem reappears. Thanks again.

PS: I'm not holding my breath on a fix from Focusrite. I'm sure the engineers are sincere, but the company has already moved on from first gen Scarletts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×