Jump to content
Phil Muir

Midi Device I/O status not recognized by hardware controller

Recommended Posts

Hi all!!

 

A number of us have been using an application called Surface Reader. This exciting new application uses your installed screen reading package to make control surfaces talk. You can read about it here:

 

http://www.raisedbar.co.uk/surfacereader/surfacereader.htm

 

However it's currently not possible to use Surface Reader in Samplitude. That's because even if you disable MIDI input and output ports they are still available in the hardware control surfaces dialog box.  I used a Behrenger BCF2000 to conduct this test.

 

I tested this theory by firstly disabling the BCF port 1 port for input and output in system/hardware controller in Samplitude.

 

I then went into MIDI devices and disabled the BCF port 1 both as an input and output port.

 

I then went back into hardware controller to see if the BCF port 1 port was still there.  It was so I enabled it an an input and output port and guess what, the faders flue up.

 

I then verified that the BCF port 1 was no longer available for use as a MIDI device by pressing the Samplitude Access record keystroke, Alt and the letter R twice quickly (equivalent to right clicking on the record button) to check the input port and pressed the Samplitude Access keystroke Alt M twice quickly (equivalent to right clicking on the mute button) to access the menu for output ports.  In both instances the MIDI port was gone.

 

Conclusion:

 

Unfortunately we won’t be able to use Surface Reader until Magix provide a fix in Samplitude that disables MIDI ports in the system/hardware controller dialog box.  That’s because there is a MIDI loop going on and we can’t stop that from happening because we can’t disable MIDI ports that we don’t want to be available for Surface reader in system/hardware controller.

Share this post


Link to post
Share on other sites

This is very unfortunate. I have tested the same behavior with a Behringer X-touch. The issue is that because Surface Reader uses virtual midi cables between the control surface hardware and the application to then get the screen reader to read these messages as intercepted, by not being able to disable the midi ports in both the midi setting dialog and in the hardware dialog,The midi connection creates a midi loop. So, the result is that you get control surface faders moving involuntarily because they are receiving unwanted midi messages from the loop.

 

This looks like a bug in the software. Magix can fix this though by allowing the user to select a checkbox to say that if midi ports are disabled in the midi dialog box, they should also be disabled in the hardware dialog box.

 

Again, it is very unfortunate and a big negative not being able to use surface reader.

 

Share this post


Link to post
Share on other sites

Hi, I'm the developer of SurfaceReader and I can confirm Phil's test results. To explain a little, SurfaceReader uses a pair of virtual MIDI cables in order for it to work as middleware between the ports that are physically connected to a given control surface and a DAW application.

 

MIDI Messages sent by the hardware are received by SurfaceReader, analysed and any required speech is output, then the message is transmitted via the first virtual cable to the DAW, which should be configured to ignore the MIDI In port that the surface is connected to and use the first virtual MIDI In port instead.

 

Similarly, when the DAW sends MIDI messages, they should be sent out using the second virtual Out port, with the physical MIDI Out port being used by the control surface being disabled. SurfaceReader receives the message, generates speech output based on its analysis, then sends it on to the output port being used by the hardware.

 

Disabling the ports being used by the control surface hardware prevents the obvious problem of duplicate messages being received. Additionally, it is necessary to configure the DAW to disable the first virtual cable's Out port and the second virtual cable's In port in order to prevent MIDI loops.

 

It would appear that disabling a MIDI port within Samplitude's MIDI dialog only disables it with respect to track operations and any such settings are not respected by any attempt to configure a control surface in the Hardware Controllers dialog.

 

Most of my users are moving from Cakewalk Sonar to Samplitude and this issue prevents them from using my software, which is a distinct downgrade with respect to this aspect of the DAW operation.

 

However, I must take this opportunity to thank the Magix development team for their efforts in supporting the Samplitude Access project - I did some of the initial coding, though Steve has taken it way beyond the point where work commitments meant that I had to leave the project. It's great to have another high-quality solution that's accessible to visually-impaired people.

 

Please contact me at:

 

tim@raisedbar.net

 

if you require any further information that might take this issue forward.

 

Best wishes.

 

Tim Burgess

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×