Jump to content
Sign in to follow this  
JoaCHIP

Windows 10 WDM and MME support broken?

Recommended Posts

I'm not sure exactly when this happened as I usually run ASIO which works well. But it seems to me that (at least) the latest Windows 10 version (v1803, build 17134.112) has completely lost support for good old WaveIn (both WDM and MME in Samplitude). No matter how nudge the M-audio 2496 and Motu 2408mk3 drivers, recording only works in ASIO mode. This goes for all the software I have, not just things made by Magix. Software that I've been using for ages on the same two soundcards in Windows 7 and earlier are no longer working.

The problem is that not all software has ASIO support.

When googling around, I only find useless "tips" like "try updating your driver" (yes, did that), "try rebooting" (yup, did that), "try enabling permissions to the mic" (new thing in Windows 10 which only lists those Metro apps that noone has anyway) and such.

Has anyone else experienced something like this with Win10? My hardware setup hasn't changed for years.

Here's what Samplitude shows when trying to record in MME or WDM mode (regardless of using 16 or 24 bit record mode, and regardless of sample rate):

Quote

 

Can't open waveform input device 'Line 1/2 (M-Audio Delta Audioph' !
(The specified format is not supported or cannot be translated.  Use the Capabilities function to determine the supported formats.)
Change driver bit resolution to 16 Bit or switch driver system to WDM compatible in system options.


 

Quote

 

Can't open waveform input device 'PCI-424 2408mk3:Analog-A 1-2 (M' !
(The specified format is not supported or cannot be translated.  Use the Capabilities function to determine the supported formats.)
Change driver bit resolution to 16 Bit or switch driver system to WDM compatible in system options.


 

I had the driver set up 16-bit resolution here btw. I've also tried SoundForge, VUmeter.exe, Wavosaur and OBS screen capture. All dead.

Any ideas?

Share this post


Link to post
Share on other sites

I use Voicemeeter to bring my ASIO interface (in my case a MOTU Ultralite mk3 hybrid) into OBS every day, and have not noticed any change. Voicemeeter is delivering via WDM/KS.

Seems odd that both your M-Audio and your PCI-424 would both require driver updates at the same time due to the same Windows 10 update!

Please definitely report back if you hear anything from either company's support!

[EDIT - Nix on that - see below!]

Terry

Share this post


Link to post
Share on other sites

Oh WAIT!!! I do know the answer - if you have EVER changed the permissions for your camera or microphone, then the new Win10 has introduced a new "master switch" that defaults to being OFF if you had changed those settings for any application at all. So, go to your permissions for the microphone and simply switch that fairly obvious master switch to "ON" (same with your camera). This affects all inputs - not just the "microphone". Sorry, should have thought of that straight off.

Terry

Share this post


Link to post
Share on other sites

Thanks for your help, but I already did both before writing here:

I have the latests drivers.

I enabled said permission.

Share this post


Link to post
Share on other sites

My Delta 1010LT was working fine in Windows 10 until it did an update. Now when trying to record in Sound Forge I get an error: 
Can't Open waveform input device ... 
(Undefined external error.) 
Change driver bit resolution to 16 Bit or switch driver system to WDM compatible in system options. 

What are the options I need to change to be able to record again?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×